Jump to content

Poor Brake


Dale-Hill
 Share

Recommended Posts

Hello,

Well my front brake is not holding for shite and its really pi**ing me off now

tar wears of after like 5 mins so no good (N) whats problem if you can help

Setup:

07 Limited edt. maggy

Booster

Neco reds

Smooth rim

Mission rim

P.s i ask boumsong what could be wrong but even he did'nt no :S

Dale

Link to comment
Share on other sites

your pads may be contaminated, and if you clean them with wrong stuff it will just make it worse as that will leave a residue on them. You could search as im sure steve @ heatsink will of posted somewhere whats best to use.

Link to comment
Share on other sites

your pads may be contaminated, and if you clean them with wrong stuff it will just make it worse as that will leave a residue on them. You could search as im sure steve @ heatsink will of posted somewhere whats best to use.

yea also, if you clean your rim, sand some of the top layer on the pads, Vice versa.

Link to comment
Share on other sites

lighter fluid on the rim.....whipe it off.......sand down the pads.....make shure they are set up square to the rim :)

Dave

thats the only things i can think of

Sweet ill try that tomorrow if step dad lends me fluid

Dale

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...