Jump to content

Another Maggy Problem


rab shropshire
 Share

Recommended Posts

Need a quick fix here.

Basically my problem is that the piston within the lever body is stuck, when i pull the lever it doesnt return to its normall position. I have taken out the piston and spring, gave them both a clean and some lube but the problem remains.

Any help would be most appreciated

Link to comment
Share on other sites

Need a quick fix here.

Basically my problem is that the piston within the lever body is stuck, when i pull the lever it doesnt return to its normall position. I have taken out the piston and spring, gave them both a clean and some lube but the problem remains.

Any help would be most appreciated

i had this on my hs11, but i coated it with silicon lube (lots) it lasted for about a couple weeks but then it started doing it again, and then leaked. ur screwed, i think a new piston and spring kit may work but im not sure,

Link to comment
Share on other sites

Done a bit of research and a few people are talking about a swollen piston, so i took it out sanded it down, stretched the spring a little, popped it back in, gave it a bleed and it seems to be working fine again, but only time will tell thanks to everyone for your help.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...