Jump to content

Havin Some Bad Luck, Any Suggestions


John planet x
 Share

Recommended Posts

Hey, today i was out on me bike, and my chain was skipping around, it was alright for just hoping around (well i thought) until i went off a wall and killed my shin and had to go to hospital :/

The alignment seems alright to be honest, doesnt really skip or nothing when you just spinning the pedals. But when you put pressure or just cycle in a line, the chain on the rear cog sorta gets pulled up into the air type thing :/.

I run on the back a 14t cog (1 week old ish) and 16t on front (same age) , and a ti bash. The cog is a fairly cheap one, and i baught a king cog that should come next week that im putting on in replacement. Im using a sora mech to tension the chain, and using a KHE chain (put on friday and this is sorta the result, but it happened before on the kmc cool but just not as much). The chain is fairly short, not uber but not big.

Any suggestions to a sound setup that i wont kill myself with, im ordering shin guards this week -_-.

Edited by John planet x
Link to comment
Share on other sites

try it again with your new cog, if it still slips tyr a chain, if you still bashin you balls then replace you rear cog aswell thatway you gotta have got rid of the problem.

i have bike's like that in the shop i work in all the time it is just a case of "trial" and error!

Link to comment
Share on other sites

when i was running single speed with a mech this happened alot to me as the tension was crappy on it. maybe the mech is abit dead? im not sure as havnt seen it oviously. also another problem i had was stiff links in the chain i was running at the time, it kept skipping over?

hope i may have helped (Y):)

Link to comment
Share on other sites

when i was running single speed with a mech this happened alot to me as the tension was crappy on it. maybe the mech is abit dead? im not sure as havnt seen it oviously. also another problem i had was stiff links in the chain i was running at the time, it kept skipping over?

hope i may have helped (Y):)

I agree with this guy, i ran a new chain and rear cog with my old mech and it was aweful kept jumping under the slightest pressure, as soon as i put my fresh products tensioner on it was fine beacuse the chain was so tight. Hasn't skipped since :D .

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...