Jump to content

Hope Mono Trials


weebryan
 Share

Recommended Posts

I have had my mono trials for a year now and i have to keep cleaning the pistons and removing the pads on a regular basis as i pull the lever nothing happens then it clicks then all a sudden they totaly lock u, is there anything a can do to prevent this? i think it is a build up off brake dust that jams the piston, not sure.

Link to comment
Share on other sites

Just a sugestion as i dont ride with a disk but.......... Maybe you need to have a re-bleed. Is there anything on youre disk because that dose'nt help. If you have a know from riding with matt that putting water on your disk helps get rid of all brake dust so that makes them sharper. (Y)

Link to comment
Share on other sites

I haved tried washing them with water and still the same, my mates does the exact same must be a common fault. They work fine after i have have cleaned the back ofthe pads and sprayed the pistons with conntact cleaner and then move the pistons in and out but only last for a short while

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

  • Recently Browsing   0 members

    • No registered users viewing this page.
×
×
  • Create New...