Jump to content

Help With Bleeding Magura


Recommended Posts

Hi sorry to post a topic about such a common problem, but when I am bleeding my magura in the bath and put back on the bleed bolts (underwater), when i pull the lever the pistons dont move! I bled the front brake earlier and that is fine but i have tried to bleed this rear brake about 10 times and it still won't work! I think that the problem is that I am not getting all the air out of the system but I am squeezing the lever till the bubbles stop coming out. I am confused :unsure: please help!

Thanks in advance and I will really appreciate it!

Link to comment
Share on other sites

I have only ever done it once and i had this problem. Theres obviusly no water in the brake <_<

Try this :

1. Fillbath full of water.

2. Take the brake off of your bike and put it in the bath.

3. Undo both bleed bolts, the one on the lever and the one on the slave. (Underwater)

4. Pump the brake and you should see some air coming out of the slave.

5. Do this until no more air comes out.

6. Do up both of the bleed bolts. (Again, underwater)

7. Take the brake out and it should be air free.

If you still dont get it try this thread i found:

Bath Bleeding maggies

Link to comment
Share on other sites

The way I used, get a bucket of water and antifreeze, jsut deep enough to put the lever in, take the bleeder out of the lever, and take the bleeder out of the end slave cylinder. With the lever submerged, depress the lever, then hold your thumb (or have a mate) over the slave cylinder, release the lever, wait a few secs (so all presure is relieved) then take your thumb off and press the lever once more, repeat this as many times as you lie, but try to do it about 20 or more for a proper flush! Then finally squeeze the lever, put the plug in the slave cylinder, release the lever and do the same up top. Has worked well for me. But i have just bought the bleed kit to save me this arsing about next time, plus i dont have a giant bucket of oil which i want to put in (Y)

Link to comment
Share on other sites

Thanks for all your help guys i've done it! I found some oil stuck in the caliper without the bleed bolt, and gave that a rinse through, then re-attached the hose underwater. Sorry for clogging up the forum with a maguras tread but i was in a rush but it's fine now! Thanks again!


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Recently Browsing   0 members

    • No registered users viewing this page.
  • Create New...